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TPLTables® for Windows

Tutorial

What Can You Do with TPL Tables?

TPL Tables lets you analyze your data and produce publication quality statisti-
cal tables. It can tabulate large and small amounts of data and produce tables that 
range in size from a few lines to hundreds of pages. You can do tabulations in an 
endless variety of ways, and you have complete control over the structure and con-
tent of your table output. 

TPL Tables automatically formats your output into quality tabular reports. Option-
ally, you can take precise control of format details such as labels and titles, column 
widths, footnotes, fonts and colors.  You can do this interactively with the results 
viewable on your screen.

Purpose of this Tutorial

This tutorial is intended to get you started in creating tables.  You will learn how 
to:

•	 Start up TPL Tables

•	 Create a simple table request interactively

•	 Run a job to produce one or more tables

•	 Edit a table interactively

•	 Export a table for use with other software

We will only touch the surface of the many things you can do, but our goal is to 
introduce you to the basics and take you through the complete process to produce a 
table.  Once you get familiar with the basics, you should be able to go quickly.
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What You Need to Produce Tables

The ingredients needed to create tables are:

•	 a data file
•	 a codebook that describes the data file, and
•	 a table request that describes the desired tables.

An optional ingredient is:

•	 a format request that makes changes to the default 
table formats.

You can create and modify these files using the interactive features in TPL Tables.  
A big advantage of using the interactive tools is that you do not need to know the 
syntax of TPL statements.  You can also create or edit codebooks, table requests, 
and format requests, using any editor that creates stand-alone ASCII text files.

For this tutorial, the data and codebook are provided.  We will create a table re-
quest and format request interactively.

The Data

The tutorial data is an extract from a CPS data file.  CPS stands for Current Popu-
lation Survey, a survey conducted by the U.S. Bureau of the Census.  The extract 
is a 1 mb file containing data collected from 30,000 households.  Each record 
contains information about one household: state of residence, household income, 
number of children in the household, sex of head of household, education level of 
head of household, and so on.

The Codebook

Codebooks contain information such as variable names, locations, sizes, and code 
values.  Once you have a codebook for your data, you can use it over and over 
again.

In the codebook, you assign types to variables, depending on how you want to use 
them in tables.  For variables that are coded or can otherwise be used to define 
categories, you would assign a type of CONTROL (or CON).  An example is state, 
where each state has a state code value.  For numeric variables that can be aggre-
gated or used in other computations, you would assign a type of OBSERVATION 
(or OBS).  An example is household income.
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The Table Request

The table request describes the tables you want.  You can reference any of the vari-
ables in your codebook by name.  In addition, you can select subsets of the data 
file, compute new variables and define new categories for existing variables.

The Format Request

TPL Tables automatically formats your tables.  If you wish, you can create a for-
mat request to make changes to the default formats.  For example, you may want 
to change the columns widths, edit a table title, add a footnote, or rotate a table to 
landscape.

Let's Get to the Action

Start TPL Tables

•	 If you have the demo version of TPL Tables:

Click on the "TPL 7.0 Demo" icon, or go to Start then Programs then QQQ Soft-
ware then TPL70 Demo then TPL.

•	 If you have the complete TPL Tables system:

Click on the "TPL 7.0" icon, or go to Start then Programs then QQQ Software 

then TPL70 then TPL.

The TPL main window will be displayed with menu options at the top. 

Make sure you are in the correct directory

Select the directory (folder) where you want to do your work.  For the instructions 
in this tutorial, you will want to be in the Examples subdirectory of the directory 
where you installed TPL Tables.  If you have just installed the software, you should 
already be there.  On some systems you will not be able to run jobs in this direc-
tory.  If this is the case, copy the files in the directory to some place where you can 
run jobs and set your job directory there.

To be sure that you are in the correct directory, click on File in the upper, left cor-
ner of the screen, then Job Directory.
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Only directories are shown in this screen, not individual files.  If the correct direc-
tory is not already highlighted, browse to the correct directory.  The path for the 
selected directory will be displayed in the space above the area showing the direc-
tory structure. 

•	 Assume that you have the demo version of TPL 
Tables and have installed it in the directory 
c:\program files\qqq software\TPL 7.0 Demo.  Then the 
selected directory should be:

C:\PROGRAM FILES\QQQ SOFTWARE\TPL 7.0 DEMO\EXAMPLES

• 	 Assume that you have the complete 
TPL Tables system and have installed it in the directory 
c:\program files\qqq software\TPL 7.0.  Then the selected 
directory should be:

C:\PROGRAM FILES\QQQ SOFTWARE\TPL 7.0\EXAMPLES

Click OK.
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Go to Table Builder

From the File menu in the upper, left corner of the TPL screen, select Build Table.

The main Table Builder screen will start up. 

To create a new table request, go to File then New.

The Create Table window will open and you will be asked to select your processed 
codebook.

Select the file:  Cps.k

(We have used the name CPS for files relating to the Current Population Survey).

When you select the codebook, the variables in the codebook will be shown in 
a list on the screen.  You will also have grids named Wafer, Head and Stub into 
which you can drag variables to build a table.
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The table Head contains the variables for the heading that goes across the table.  In 
other words, it determines the columns.

The table Stub contains the variables that go down the side of the table.  In other 
words, it determines the rows.

The Head and Stub form the core of a table.  Optionally, this core can be repeated 
for a "stack" of Wafers as shown in the following illustration.
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Design a Table

Many, many different tables can be requested using variables in different combina-
tions.  For a quick start, we will do a simple table.

You can use the context-sensitive Help for complete information about how vari-
ables can be arranged in a table.  To get context-sensitive Help on the Create 
Table screen or any other TPL screen, position your cursor over an item on the 
screen, hold down your mouse button and press <F1>.  For example, to get Help 
on how variables can be arranged in the table Stub, position your cursor in the 
Stub grid, hold down your mouse button, and press <F1>.

Now, for the table Head, select the variable HOUSEHOLD_TYPE from the list 
of variables (you may need to scroll up or down on the list to get to it).  Position 
your cursor on the variable name HOUSEHOLD_TYPE, hold down the left mouse 
button, and drag the variable to the Head grid.
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Initially, the variable will occupy only one rectangle of the grid.  If the rectangle is 
too small to contain the complete variable name, you can position the cursor on top 
of the rectangle and hold down the right mouse button to get the full name dis-
played at the bottom of the screen.

You can also stretch the rectangle as shown in the illustration.  This stretching 
can be used to create table headings with multiple variables as described in Table 
Builder Help.  To see some examples, position your cursor in the Head grid, hold 
down your mouse button, and press <F1>.

Now, for the table Stub, scroll to the variable named EDUCATION on the variable 
list and drag it to the Stub grid.
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Note that for each variable in the list of variables, you can get more information by 
double-clicking on the variable, either in the grid or in the list of variables.  Since 
EDUCATION has a type of CON (Control), clicking on the Conditions button will 
bring up a list of the 6 values (called condition values) for EDUCATION.
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With EDUCATION in the table stub, the table will have 6 rows, one for each of 
the 6 values of EDUCATION.

As part of your table request, you may also select subsets of the data, define 
variables with new categories, and compute new variables.  But, you already have 
everything you need to produce your first table.

From the File menu at the top, left corner of the screen, select Save As....  You 
will be prompted to provide a File name.  Enter the File name:  Tutor1.req  and 
click Save.

With your saved table request, you can now produce a table.  You can also go back 
to Table Builder at any time, open your saved table request, and make changes to 
it.

From the menu bar at the top of the screen, select Return to TPL.  You will go 
back to the main TPL screen. 
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Produce the Table

To produce the table, click on the Run menu at the top of the main TPL screen 
and select Table Request.

You will be asked to enter file names for the run.

Enter or browse for the names of the Request File (tutor1.req) and the Data File 
(cps.dat) in the Examples subdirectory.  You do not need to enter a name for the 
optional Format File.  The  bottom line specifies a subdirectory where the table and 
other outputs for the run will be saved.  If you wish, you can override the gener-
ated number on the right with your own choice.  In this example, we have entered 
a 1.

Note:  If, at any time, you browse for file names and do not see names that match 
these instructions, please see the "Note on File Extensions" at the end of this 
tutorial.
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Click OK.  TPL Tables will read your data and prepare the table.  When it is fin-
ished, you will see a screen that looks like this:

To look at the output, click on the Edit/Print button.

You will be transferred to TED, the TPL editor.  In TED, you can view outputs, 
print them, edit tables interactively, and export them.

In TED, there will be two file windows open.  Depending on the relative sizes of 
your file windows, you may see both or only the table on top.  The other file is 
called output and contains information about your job.
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Maximize the file window with the table so that you can see the entire table.  The 
table file is called tables.ps.

TABLE 1

Type of Household

Married
couple

Other
family

Nonfamily
household

Educational Attainment of
Householder

8 years or less ........................ 1,990 699 1,297
High school, 1 to 3 years ........ 1,935 703 1,061
High school, 4 years ............... 6,405 1,769 2,701
College, 1 to 3 years ............... 2,939 666 1,454
College, 4 years ...................... 2,142 268 1,056
College, 5 or more years ........ 1,853 195 867

This sample table was prepared using TPL Tables.

QQQ Software, Inc. Arlington, Virginia USA
703-528-1288 voice   703-528-1289 fax

info@qqqsoft.com email   www.qqqsoft.com web

Notice that the table has a default title of TABLE 1.  We could have given it a nicer 
title when we were in Table Builder, but we can also change it now that we have 
the finished table.
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Edit the Table

If you double-click on any part of the table on the screen.  You will be presented 
with options for changing the table.

To go directly to title options, double-click on the table title.

In the screen for title options, click in the box to the left of Title, then click on the 
Edit button below the title. 
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You will be transferred to the label editor where you can modify the title as you 
wish.

For example, replace the text with:

 Tutorial Table 1 -- Households by Education and Type of Residence 

  

Click OK.
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Back at the Title screen, click the Apply button.

The table will be re-formatted with the new title.

Tutorial Table 1 -- Households by Education and
Type of Residence 

Type of Household

Married
couple

Other
family

Nonfamily
household

Educational Attainment of
Householder

8 years or less ........................ 1,990 699 1,297
High school, 1 to 3 years ........ 1,935 703 1,061
High school, 4 years ............... 6,405 1,769 2,701
College, 1 to 3 years ............... 2,939 666 1,454
College, 4 years ...................... 2,142 268 1,056
College, 5 or more years ........ 1,853 195 867

This sample table was prepared using TPL Tables.

QQQ Software, Inc. Arlington, Virginia USA
703-528-1288 voice   703-528-1289 fax

info@qqqsoft.com email   www.qqqsoft.com web

For more information on interactive editing of tables, go to TED Help and choose 
the topic "Using Ted to Review, Edit, Print, and Export Tables" under "Getting 
Started".  Then choose the topic "Using Ted to Format Tables".
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Printing

If you wish, you can print the table from TED by going to File then Print.  Al-
though the table is PostScript, you do not need a PostScript printer to print it from 
TED.

Exporting

In addition to printing, you can Export a table file to a variety of other formats.

With the table still on the screen in Ted as the active the window, click on File 
then Export.  You will be transferred to the Export screen.

As an example, we will export an HTML file.  Exported HTML files can be 
opened with any software that reads HTML, regardless of the export options se-
lected.  The other software could be a browser, a spreadsheet, or a word processor.  
These different types of software have different ways of displaying the HTML.
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If you are going to open the HTML in Microsoft Excel, it will look best if it is ex-
ported using the option labeled Web (Excel compatible html).  To do this, simply 
click on this option and then click on the Export button.  

•	 Assuming that you have the demo version of 
TPL Tables and have installed it in the directory 
C:\PROGRAM FILES\QQQ SOFTWARE\TPL 7.0 DEMO, the 
HTML file will be:

C:\PROGRAM FILES\QQQ SOFTWARE\TPL 7.0 DEMO\EXAMPLES\Examples\
TPL1\Table1.HTM

• 	 Assuming that you have the complete 
TPL Tables system and have installed it in the directory 
C:\PROGRAM FILES\QQQ SOFTWARE\TPL 7.0, the HTML 
file will be:

C:\PROGRAM FILES\QQQ SOFTWARE\TPL 7.0\EXAMPLES\Examples\TPL1\
Table1.HTM

You may wish to open this file with some other software to see what it looks like.  
For example, in your web browser, you can go to File then Open Page and select 
the file Table1.HTM.  The display will look like the following illustration, or simi-
lar to it depending on which browser you are using.

Finishing the Job

If you would like to save your format changes as a Format Request and re-
use them in the future to re-create the table with your changes, click on File 
then Save Format....
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To return to the main TPL screen, click on Return to TPL then Resume in the 
menu bar at the top of the TED screen.

In the main TPL screen, click Close in the Status screen.

Now you can exit TPL with File then Quit, or you can go to Table Builder again to 
try another table.

Notes on File Extensions

All of the file names used in this tutorial and other TPL demonstration jobs have 
extensions (suffixes), such as .REQ or .DAT.  If your Windows system is config-
ured to hide file extensions of "known file types", you may find that some of the 
extensions for the files are not visible when you browse for file names.  In some 
cases, this may make it impossible to tell one file from another.  If you have this 
problem, we suggest that you change your settings so that complete file names are 
shown.

Following are instructions for changing the treatment of file extensions.  The in-
structions vary slightly from one Windows version to another.

You may need to close TPL and restart it to make the change effective.

Windows XP or Vista
Go to Start.  Select Control Panel.  Select Folder Options.  (If you do not see 
Folder Options, look for Appearance and Themes or Appearance and Person-
alization), then Folder Options under it.)  Then select the View tab.  Now unclick 
"Hide extensions for known file types".
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Windows 2000
Go to Start then Settings and select Folder Options.  Click the View tab.  The 
option to "Hide file extensions for known file types" should not be selected.

Windows 98
In Windows Explorer, go to the View menu and click Folder Options.  Click the 
View tab.  The option to "Hide file extensions for known file types" should not be 
selected.

Windows NT
In Windows NT Explorer, go to the View menu and click Options.  Click the 
View tab.  The option to "Hide file extensions for known file types" should not be 
selected.
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